Go Back   North East F-Body Association > Tech > Drivetrain

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-14-2014, 01:22 AM
KB93z28's Avatar
KB93z28 KB93z28 is offline
Chopper Challenge Champion
Join Date: Dec 2010
Location: Whitinsville, MA
Posts: 1,189
Post Thanks / Like
Thanks (Given): 53
Thanks (Received): 24
Likes (Given): 97
Likes (Received): 136
Dislikes (Given): 7
Dislikes (Received): 10

Wow, thanks a lot man! Great links! My clutch fluid does look pretty dirty, so I'm just gonna start with the simplest things first and work my way down until I solve the problem. Or I could just go out and buy a whole new slave and master cylinder assembly, do the drill mod while its still out of the car and then throw it in...... Ill have to look at prices for the assembly. I remember buying a sealed unit for my 93 that could just bolt in the car and was already bled and good to go. Well see.
1993 BGGM Z28, stock LT1, T56, 175k on original motor, basic bolt-ons. 273 whp, 308wtq. SOLD
2001 Black WS6 TA Stock....for now....
DD: 2007 Dodge Ram 1500 quad cab sport, 6 inch RCX lift, 35x13.5 tires, 20x9 Fuel wheels, 20% tint all the way around, ZZ customs exhaust, Diablosport Trinity T1000 programmer.
Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

All times are GMT. The time now is 09:40 AM.

Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.