Go Back   North East F-Body Association > F-Body Garage > Project Logs

Reply
 
Thread Tools Display Modes
  #21  
Old 09-23-2014, 11:38 PM
Z28's Avatar
Z28 Z28 is offline
Runs 19's
 
Join Date: Sep 2012
Location: Westboro
Posts: 871
Post Thanks / Like
Thanks (Given): 23
Thanks (Received): 32
Likes (Given): 169
Likes (Received): 176
Dislikes (Given): 3
Dislikes (Received): 5
Default

Nah man you'll be fine, we get cars hit harder than that at my work all the time just make sure you send it to the right people
__________________
Victory Red 1994 Z28
in progress
Black 2000 S10
lowered/daily
Reply With Quote
  #22  
Old 09-26-2014, 09:59 PM
84ta406 84ta406 is offline
Future club Dangle member
 
Join Date: Oct 2009
Location: Worcester, MA
Posts: 1,802
Post Thanks / Like
Thanks (Given): 15
Thanks (Received): 16
Likes (Given): 58
Likes (Received): 54
Dislikes (Given): 2
Dislikes (Received): 3
Default

Took the belt off and fired it up again. The odd noise is gone so now I know its not the motor. Kind of idles real low but with everything wrong Im sure thats the reason.

Started taking apart the hub assembly. Got new upper and lower control arms. New ball joints etc. To put in. Torque arm is in now. Everything out back looks to be pretty square. Gonna bring home the alignment equiptment and check it all.

Not too much to report in but Im slowly pecking at it. Goal is to have the car at my house garage in two weeks where Ill take off the old fender and door.
__________________
5.3L LSx, Fbody .500 cam, TH400, 4500 Stall, Moser 9"
Reply With Quote
  #23  
Old 09-26-2014, 11:51 PM
ILuvPizzaTimes10's Avatar
ILuvPizzaTimes10 ILuvPizzaTimes10 is offline
YOUR ALL GUNNA DIE!!!
 
Join Date: Oct 2009
Location: Randolph, MA
Posts: 9,380
Post Thanks / Like
Thanks (Given): 21
Thanks (Received): 192
Likes (Given): 65
Likes (Received): 587
Dislikes (Given): 25
Dislikes (Received): 83
Default

nice!!! low idle with belt on alt or off?
__________________


1998 Firebird:buncha parts thats used to make it go fast..... not so much anymore.
BAAAAAA!!!!!!
Reply With Quote
  #24  
Old 09-27-2014, 12:12 AM
84ta406 84ta406 is offline
Future club Dangle member
 
Join Date: Oct 2009
Location: Worcester, MA
Posts: 1,802
Post Thanks / Like
Thanks (Given): 15
Thanks (Received): 16
Likes (Given): 58
Likes (Received): 54
Dislikes (Given): 2
Dislikes (Received): 3
Default

Seemed low last week and today. Like 650 rpm with the clutch in and like 500 in neutral. I ran it today with no belt on but I had it jumped to another car the whole time so it was seeing 14v ish. Gonna try and charge the battery for good and see how it goes. Could also use some fresh gas and such.
__________________
5.3L LSx, Fbody .500 cam, TH400, 4500 Stall, Moser 9"
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 02:14 PM.


Powered by vBulletin® Version 3.8.4
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.